Discussion:
Old wine and intel graphics problem
(too old to reply)
eerozeteen . via arch-general
2017-01-15 12:59:46 UTC
Permalink
Raw Message
Hello,

Im trying to run Lineage2 Interlude on my laptop (processor Intel Core
i5-560M with integrated intel graphics) via Wine [1]. 1.5.0 is the last
wine version where people can run Lineage2 Interlude. Im used playonlinux
to create prefix with 1.5.0 and try to run a game. Unfortunately
playonlinux debug utility shows problem with libGL:

libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: i965_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: i965
libGL error: unable to load driver: swrast_dri.so
libGL error: failed to load driver: swrast

I googling a lot, but every solution has a reference to Steam problem and
dont works on my problem.
Where can be problem? Drivers? Incompatibility old wine with system or
graphics?

Im tried run this same on different laptop (older then my, and with intel
graphics too), and have same problem.

Maybe is any workaround to make it work?

[1] - https://appdb.winehq.org/objectManager.php?sClass=version&iId=9115

Regards
eerozeteen
LoneVVolf
2017-01-15 13:35:42 UTC
Permalink
Raw Message
Post by eerozeteen . via arch-general
Hello,
Im trying to run Lineage2 Interlude on my laptop (processor Intel Core
i5-560M with integrated intel graphics) via Wine [1]. 1.5.0 is the last
wine version where people can run Lineage2 Interlude.
It looks like you misunderstand what test results in wine AppDB mean.

No one has tested LI2 interlude with a version past 1.5.0, but that
doesn't mean it will fail with later versions .

Just try running it with latest wine, there's a big chance it will work.

LW
eerozeteen . via arch-general
2017-01-17 10:22:17 UTC
Permalink
Raw Message
Date: Sun, 15 Jan 2017 14:35:42 +0100
From: LoneVVolf
Post by LoneVVolf
No one has tested LI2 interlude with a version past 1.5.0, but that
doesn't mean it will fail with later versions .
Post by LoneVVolf
Just try running it with latest wine, there's a big chance it will work.
No one has tested, because game fail to start without any output in
terminal. Of course winedebug += all shows wall of text, but i didnt see
any hook to move forward. I wrote on server forum, that people play on
ubuntu (with 1.5.0) as well. But i dont know what kind of graphics card
they are using. So this is a reason, that im trying run game on 1.5.0. I
know that problem can be in libgcrypt or something like that. There is a
lot workarounds to steam with this error. Can downgrade libgcrypt help with
it? How far you should go back? But i know that isnt safe.

Regards
eerozeteen

Loading...