problems accessing samba share through Xfce gui
(too old to reply)
Paul Marwick via arch-general
2017-06-14 13:28:57 UTC
Raw Message
Arch Linux, fully updated, running Xfce, installed on a Lenovo T420
laptop. I’m having strange, intermittent problems accessing samba shares
through the GUI.

The problem varies, no pattern that I can detect. Sometimes, clicking on
the “Browse Network” icon in Thunar does nothing, eventually returning
‘Failed to open “/” Timeout reached’ . Other times it will open the
network view and allow me to double-click the Windows Network icon.
Sometimes that is the last thing that happens (possibly followed by
another timeout error, though that can take so long that I may have shut
the machine down before it happens). If it gets past the main Windows
network stage, it will show me any active workgroup. It may fail there,
or it may give me a view of the machines in the workgroup. It may allow
me to select a machine, and may show me the shares on the machine. If I
double-click on a share, it will (sometimes) pop up the login dialog. If
that fails, sometimes double-clicking a second time will show the login

If I am able to connect to a share, there is (sometimes) a further
problem. Using the Thunar option to disconnect from the share works, but
if I attempt to reconnect to the share, or connect to another share,
instead of opening the share in Thunar, it opens VLC, which doesn’t
understand what is going on and does nothing.

I have two other Arch installations on my laptop, plus two desktop
machines which run Arch. None of the other installations have any
similar problems. The Arch installs are all very similar in terms of how
they were installed and the software they have on them. Also, the
install which is giving me this problem developed it – originally it
worked without any errors. I mad a mistake configuring the samba server
on an Ubuntu 16.04 server and followed that up by attempting to access
the share from my Arch install. This problem has been happening ever
since then, but only on the one install.

I’ve checked the systemd journal and found absolutely nothing to help me
diagnose the problem. This install does have on problem which shows
consistently during boot - I get a core dump in the systemd journal from
colord-sane (which is installed on the other installs as well). However,
while the core dump happens on every boot, the samba problem only
happens on some, so I don't think the problem comes from there.

I’m fairly sure that the problem is not Thunar itself (I’ve tried
PcmanFM, which shows similar inconsistent behaviour – sometimes it will
connect without problems, other times pcmanfm locks up and does nothing,
has to be forced closed. I also installed gigolo, which also shows
similar problems.

I think the problem is in one of the back-end programs which handles
mounting the shares. I guess that includes gvfs, fuse and possibly
d-bus. I’ve not managed to find an explanation of exactly what is used
when mounting a share using the gui.

I should also mention that when this happens, I can mount the shares
without problems from the command line, or using mount with suitable
entries in /etc/fstab. Also, thinking that there might be something
messed up in my user profile, I added another user and tested using that
user. Problem is exactly the same - sometimes the mount works without
errors, others it fails in the same unpredictable manner.

While I could fix the problem by reinstalling, this is one of the few
things I’ve ever hit in Arch that (so far), I’ve been unable to fix. I
would really love to be able to fix it, but that means I need to have
some way of diagnosing where the problem is. Any help would be very
gratefully received.
2017-06-14 13:39:33 UTC
Raw Message
... Any help would be very gratefully received.
have you tried reinstalling gvfs-smb?
Paul Marwick via arch-general
2017-06-14 14:18:05 UTC
Raw Message
Post by ITwrx.org
... Any help would be very gratefully received.
have you tried reinstalling gvfs-smb?
Yes, one of the first things I tried. Makes no difference. It almost
looks like some sort of timing issue, but I've so far not managed to
find anything that looks like the culprit.

I've seen some of this problem before - I had Sparky Linux installed on
my last laptop (mainly to support someone else). Its based on Debian
testing and there was a period of some weeks when it came up with the
first error - 'Unable to open "/" on . Timeout was reached'. Whatever
was causing that was fixed in Debian testing and hasn't come back.
Though that one never showed the variability of the problem I'm seeing.