Discussion:
Problem install slack-desktop deb
(too old to reply)
Maykel Franco via arch-general
2017-06-13 14:21:53 UTC
Permalink
Raw Message
Hi, recently I like install slack-desktop 2.3.4 because with the
latest version 2.6.x I have a problem with unmark read messages bug...

I have install debtap from github, the binary because the debtap
archlinux repository not works well.

When install the slack-desktop 2.3.4 deb I get this error...

user ~/ $ LANG=C sudo pacman -U
slack-desktop-2.3.4-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "apt", a dependency of "slack-desktop"
warning: cannot resolve "gir1.2-gnomekeyring-1.0", a dependency of
"slack-desktop"
:: The following package cannot be upgraded due to unresolvable
dependencies:
slack-desktop

:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: slack-desktop: requires apt
:: slack-desktop: requires gir1.2-gnomekeyring-1.0


How resolved it?

Thanks in advanced.
Jelle van der Waa
2017-06-13 14:26:24 UTC
Permalink
Raw Message
Post by Maykel Franco via arch-general
Hi, recently I like install slack-desktop 2.3.4 because with the
latest version 2.6.x I have a problem with unmark read messages bug...
I have install debtap from github, the binary because the debtap
archlinux repository not works well.
When install the slack-desktop 2.3.4 deb I get this error...
user ~/ $ LANG=C sudo pacman -U
slack-desktop-2.3.4-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "apt", a dependency of "slack-desktop"
warning: cannot resolve "gir1.2-gnomekeyring-1.0", a dependency of
"slack-desktop"
:: The following package cannot be upgraded due to unresolvable
slack-desktop
:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: slack-desktop: requires apt
:: slack-desktop: requires gir1.2-gnomekeyring-1.0
How resolved it?
It's better to not rely on unofficial (shit) like debtap and work on
fixing the package in the repos.
--
Jelle van der Waa
Maykel Franco via arch-general
2017-06-13 14:31:38 UTC
Permalink
Raw Message
Post by Jelle van der Waa
Post by Maykel Franco via arch-general
Hi, recently I like install slack-desktop 2.3.4 because with the
latest version 2.6.x I have a problem with unmark read messages bug...
I have install debtap from github, the binary because the debtap
archlinux repository not works well.
When install the slack-desktop 2.3.4 deb I get this error...
user ~/ $ LANG=C sudo pacman -U
slack-desktop-2.3.4-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "apt", a dependency of "slack-desktop"
warning: cannot resolve "gir1.2-gnomekeyring-1.0", a dependency of
"slack-desktop"
:: The following package cannot be upgraded due to unresolvable
slack-desktop
:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: slack-desktop: requires apt
:: slack-desktop: requires gir1.2-gnomekeyring-1.0
How resolved it?
It's better to not rely on unofficial (shit) like debtap and work on
fixing the package in the repos.
--
Jelle van der Waa
How to fixing the package specific version 2.3.4 in repo??
Jelle van der Waa
2017-06-13 16:37:16 UTC
Permalink
Raw Message
Post by Maykel Franco via arch-general
Post by Jelle van der Waa
Post by Maykel Franco via arch-general
Hi, recently I like install slack-desktop 2.3.4 because with the
latest version 2.6.x I have a problem with unmark read messages bug...
I have install debtap from github, the binary because the debtap
archlinux repository not works well.
When install the slack-desktop 2.3.4 deb I get this error...
user ~/ $ LANG=C sudo pacman -U
slack-desktop-2.3.4-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "apt", a dependency of "slack-desktop"
warning: cannot resolve "gir1.2-gnomekeyring-1.0", a dependency of
"slack-desktop"
:: The following package cannot be upgraded due to unresolvable
slack-desktop
:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: slack-desktop: requires apt
:: slack-desktop: requires gir1.2-gnomekeyring-1.0
How resolved it?
It's better to not rely on unofficial (shit) like debtap and work on
fixing the package in the repos.
--
Jelle van der Waa
How to fixing the package specific version 2.3.4 in repo??
The package is not even in our repos, but in the AUR and since the AUR
is unsupported ask the maintainer of even better ask upstream.
--
Jelle van der Waa
Óscar García Amor
2017-06-14 09:29:37 UTC
Permalink
Raw Message
Post by Jelle van der Waa
Post by Maykel Franco via arch-general
Hi, recently I like install slack-desktop 2.3.4 because with the
latest [..]
The package is not even in our repos, but in the AUR and since the AUR
is unsupported ask the maintainer of even better ask upstream.
Hi!

You can use this PKGBUILD [1] (this commit [2]) to make 2.3.4 version.

Anyway I don't recommend use old versions of packages because it may
have bugs or security issues.

In the other hand, if you read the comments on AUR package you can see
one by IlyaGulya that says:

If anyone experiences the problem with marking messages as read, you
should clear Slack cache simply removing the ~/.config/Slack/Cache
directory

I recommend the "clear cache procedure" as first step to fix slack problems.

Greetings

[1]: https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=slack-desktop&id=e37430fb37416b9ef47f480ad108891db96be413
[2]: https://aur.archlinux.org/cgit/aur.git/tree/?h=slack-desktop&id=e37430fb37416b9ef47f480ad108891db96be413
--
Óscar García Amor | ogarcia at moire.org | http://ogarcia.me
ITwrx.org
2017-06-13 14:44:02 UTC
Permalink
Raw Message
Post by Maykel Franco via arch-general
Hi, recently I like install slack-desktop 2.3.4 because with the
latest version 2.6.x I have a problem with unmark read messages bug...
I have install debtap from github, the binary because the debtap
archlinux repository not works well.
When install the slack-desktop 2.3.4 deb I get this error...
user ~/ $ LANG=C sudo pacman -U
slack-desktop-2.3.4-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "apt", a dependency of "slack-desktop"
warning: cannot resolve "gir1.2-gnomekeyring-1.0", a dependency of
"slack-desktop"
:: The following package cannot be upgraded due to unresolvable
slack-desktop
:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: slack-desktop: requires apt
:: slack-desktop: requires gir1.2-gnomekeyring-1.0
How resolved it?
Thanks in advanced.
pacman is telling you that slack-desktop cannot be upgraded because it
needs those other 2 packages(apt and gir1.2-gnomekeyring-1.0) the second
evidently being an ubuntu specific package name. you could try and get
those dependencies installed then try to upgrade slack-desktop. It may
be more trouble than it's worth.
Maykel Franco via arch-general
2017-06-13 16:04:34 UTC
Permalink
Raw Message
Post by ITwrx.org
Post by Maykel Franco via arch-general
Hi, recently I like install slack-desktop 2.3.4 because with the
latest version 2.6.x I have a problem with unmark read messages bug...
I have install debtap from github, the binary because the debtap
archlinux repository not works well.
When install the slack-desktop 2.3.4 deb I get this error...
user ~/ $ LANG=C sudo pacman -U
slack-desktop-2.3.4-1-x86_64.pkg.tar.xz
loading packages...
resolving dependencies...
warning: cannot resolve "apt", a dependency of "slack-desktop"
warning: cannot resolve "gir1.2-gnomekeyring-1.0", a dependency of
"slack-desktop"
:: The following package cannot be upgraded due to unresolvable
slack-desktop
:: Do you want to skip the above package for this upgrade? [y/N]
error: failed to prepare transaction (could not satisfy dependencies)
:: slack-desktop: requires apt
:: slack-desktop: requires gir1.2-gnomekeyring-1.0
How resolved it?
Thanks in advanced.
pacman is telling you that slack-desktop cannot be upgraded because it
needs those other 2 packages(apt and gir1.2-gnomekeyring-1.0) the second
evidently being an ubuntu specific package name. you could try and get
those dependencies installed then try to upgrade slack-desktop. It may
be more trouble than it's worth.
I decompress slack-desktop-tar.xz and exec manually bin slack and
works well!! With the version 2.3.4.
Loading...