Discussion:
Antergoes problem.
Add Reply
Matthew Dyer via arch-general
2018-08-22 16:46:41 UTC
Reply
Permalink
Raw Message
Hi all,


Just installed antergoes which is an arch diribitive distro.  Any how I
have yaourt  Enabled to install packages from the AUR.  When I attempted
to install or update packages with yaourt I get command not found.  For
example, when I type yaourt -S espeak-ng-git I get the responce, "bash
command not found."  any ideas on this.  has something changed that I am
unare of.   I never had this problem with this before.  Thanks all.


Matthew
Doug Newgard via arch-general
2018-08-22 16:51:18 UTC
Reply
Permalink
Raw Message
On Wed, 22 Aug 2018 12:46:41 -0400
Post by Matthew Dyer via arch-general
Hi all,
Just installed antergoes which is an arch diribitive distro.  Any how I
have yaourt  Enabled to install packages from the AUR.  When I attempted
to install or update packages with yaourt I get command not found.  For
example, when I type yaourt -S espeak-ng-git I get the responce, "bash
command not found."  any ideas on this.  has something changed that I am
unare of.   I never had this problem with this before.  Thanks all.
Matthew
If you're on Antergos, go ask the Antergos people.

https://wiki.archlinux.org/index.php/Code_of_conduct#Arch_Linux_distribution_support_.2Aonly.2A
Matthew Dyer via arch-general
2018-08-22 19:40:07 UTC
Reply
Permalink
Raw Message
Post by Doug Newgard via arch-general
On Wed, 22 Aug 2018 12:46:41 -0400
Post by Matthew Dyer via arch-general
Hi all,
Just installed antergoes which is an arch diribitive distro.  Any how I
have yaourt  Enabled to install packages from the AUR.  When I attempted
to install or update packages with yaourt I get command not found.  For
example, when I type yaourt -S espeak-ng-git I get the responce, "bash
command not found."  any ideas on this.  has something changed that I am
unare of.   I never had this problem with this before.  Thanks all.
Matthew
If you're on Antergos, go ask the Antergos people.
The problem seems to be saulved yaourt is in the antergoes repo so it
should be fixed now and all seems to be well.  I would have asked them,
but did not find the forms to see what I cocould do about it.
Post by Doug Newgard via arch-general
https://wiki.archlinux.org/index.php/Code_of_conduct#Arch_Linux_distribution_support_.2Aonly.2A
Steve Ovens via arch-general
2018-08-22 16:52:09 UTC
Reply
Permalink
Raw Message
I suspect its something broken with 'yaourt'. According to
https://wiki.archlinux.org/index.php/AUR_helpers#Active yaourt has been
flagged as Discontinued or problematic.

However, Antergos has its own forums you may ask there: forum.antergos.com

On Wed, Aug 22, 2018 at 12:46 PM, Matthew Dyer via arch-general <
Post by Matthew Dyer via arch-general
Hi all,
Just installed antergoes which is an arch diribitive distro. Any how I
have yaourt Enabled to install packages from the AUR. When I attempted to
install or update packages with yaourt I get command not found. For
example, when I type yaourt -S espeak-ng-git I get the responce, "bash
command not found." any ideas on this. has something changed that I am
unare of. I never had this problem with this before. Thanks all.
Matthew
--
Steve Ovens
Consultant, RHCA DevOps
Red Hat Canada
Cell: 519-709-5775
Ralf Mardorf
2018-08-22 17:21:14 UTC
Reply
Permalink
Raw Message
Post by Steve Ovens via arch-general
I suspect its something broken with 'yaourt'. According to
https://wiki.archlinux.org/index.php/AUR_helpers#Active yaourt has been
flagged as Discontinued or problematic.
Ignoring that Antergoes isn't supported by this mailing list, AUR
helpers aren't supported by Arch Linux.

"Warning: AUR helpers are not supported by Arch Linux. You should
become familiar with the manual build process in order to be prepared
to troubleshoot problems." -
https://wiki.archlinux.org/index.php/AUR_helpers

To keep it short,

$ pacman -Q yaourt
yaourt 1.9-1

does work. A yaourt feature doesn't work properly, there's an issue
with showing AUR comments, but that has got no impact on the build
process. Yaourt does a good job, it suffers from minor pitfalls. By
default it builds in /tmp, which usually is a tmpfs, so it could be too
small to build some software. If you build manually in a too small
tmpfs, it's the same issue ;).

If a command isn't found, it's usually an issue that isn't related to
discontinued or problematic software. It's an issue on it's own.

$ hahaha -S espeak-ng-git
bash: hahaha: command not found
$ which yaourt
/usr/bin/yaourt
$ which hahaha
which: no hahaha in
(/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/lib/icecat:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
Eli Schwartz via arch-general
2018-08-22 17:23:50 UTC
Reply
Permalink
Raw Message
Post by Ralf Mardorf
Post by Steve Ovens via arch-general
I suspect its something broken with 'yaourt'. According to
https://wiki.archlinux.org/index.php/AUR_helpers#Active yaourt has been
flagged as Discontinued or problematic.
Ignoring that Antergoes isn't supported by this mailing list
Can you please refrain from willfully ignoring this fact.

Thanks.
--
Eli Schwartz
Bug Wrangler and Trusted User
Ralf Mardorf
2018-08-22 17:32:51 UTC
Reply
Permalink
Raw Message
Post by Eli Schwartz via arch-general
Post by Ralf Mardorf
Post by Steve Ovens via arch-general
I suspect its something broken with 'yaourt'. According to
https://wiki.archlinux.org/index.php/AUR_helpers#Active yaourt has
been flagged as Discontinued or problematic.
Ignoring that Antergoes isn't supported by this mailing list
Can you please refrain from willfully ignoring this fact.
No problem!

Could you please post a complete sentence?
Post by Eli Schwartz via arch-general
Ignoring that Antergoes isn't supported by this mailing list, AUR
helpers aren't supported by Arch Linux.
What I tried to point out is, that AUR helpers aren't supported at all,
let alone that "bash: yaourt: command not found" or what ever else
"bash command not found" the OP gets, already is a pointer in the right
direction.

A short reply, does cause less annoying traffic, than beeing more
Catholic than the Pope.
Guus Snijders via arch-general
2018-08-22 17:46:13 UTC
Reply
Permalink
Raw Message
Post by Ralf Mardorf
Post by Eli Schwartz via arch-general
Post by Ralf Mardorf
Post by Steve Ovens via arch-general
I suspect its something broken with 'yaourt'. According to
https://wiki.archlinux.org/index.php/AUR_helpers#Active yaourt has
been flagged as Discontinued or problematic.
Ignoring that Antergoes isn't supported by this mailing list
Can you please refrain from willfully ignoring this fact.
No problem!
Could you please post a complete sentence?
I'd guess the helpfulness is appreciated, but an off-list reply would have
helped to keep the noise down.


Mvg, Guus Snijders
Ralf Mardorf
2018-08-22 18:48:16 UTC
Reply
Permalink
Raw Message
Post by Guus Snijders via arch-general
I'd guess the helpfulness is appreciated, but an off-list reply would
have helped to keep the noise down.
Somebody replied to the list that 'yaourt' seems to be discontinued or
problematic. This might be correct or incorrect, it's just not related
to a "command not found" issue, so posting to the list isn't completely
unreasonable. However, yes, I should have replied off-list, but at
least Eli and you should have done this, too ;).
null via arch-general
2018-08-22 17:00:59 UTC
Reply
Permalink
Raw Message
On Wed, 22 Aug 2018 12:46:41 -0400
Post by Matthew Dyer via arch-general
Hi all,
Just installed antergoes which is an arch diribitive distro.  Any how I
have yaourt  Enabled to install packages from the AUR.  When I attempted
to install or update packages with yaourt I get command not found.  For
example, when I type yaourt -S espeak-ng-git I get the responce, "bash
command not found."  any ideas on this.  has something changed that I am
unare of.   I never had this problem with this before.  Thanks all.
Matthew
Not to be the bearer of bad news, but Antergos is not officially supported by the Arch Linux Distribution.
This would be more suited for the Antergos Community: forum, irc, mailing list.
-freq
Loading...