Discussion:
Failed install rocketchat-desktop archlinux
(too old to reply)
Maykel Franco via arch-general
2018-04-30 20:25:00 UTC
Permalink
Raw Message
Hi, I get this error when install the rocketchat-desktop:

[4/4] Building fresh packages...
$ electron-builder install-app-deps
• electron-builder version=19.56.0
• loaded configuration file=package.json ("build" field)
• rebuilding native production dependencies platform=linux arch=x64
• rebuilding native dependency name=spellchecker
• rebuilding native dependency name=@paulcbetts/system-idle-time
Done in 17.92s.
yarn run v1.6.0
$ gulp build --env=production
gulp[2126]: ../src/node_contextify.cc:631:static void
node::contextify::ContextifyScript::New(const
v8::FunctionCallbackInfo<v8::Value>&): Assert
ion `args[1]->IsString()' failed.
1: node::Abort() [gulp]
2: 0x55a77757c9db [gulp]
3: node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value>
const&) [gulp]
4: v8::internal::FunctionCallbackArguments::Call(v8::internal::CallHandlerInfo*)
[gulp]
5: 0x55a777791ba7 [gulp]
6: 0x55a77779233c [gulp]
7: 0x36bc07f0427d
error Command failed with signal "SIGABRT".
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about
this command


Why this error? How to solved it?

Thanks in advanced.
Tasnad Kernetzky via arch-general
2018-05-02 12:16:13 UTC
Permalink
Raw Message
Hi,

I had a similar issue with another package, it was related with old
versions of packages.

I could solve it with the following commands in the sources directory:

rm -rf node_modules # or backup, whatever
rm -rf package-lock.json # or backup, whatever
npm cache clean # I guess I had to use --force here
npm install # this was my command, yours will probably be different


Maybe this helps and maybe you'll have to adopt it to yarn, I'm really
not an expert with npm / gulp / yarn / whatever...

Regards,
Tasnad
Post by Maykel Franco via arch-general
[4/4] Building fresh packages...
$ electron-builder install-app-deps
• electron-builder version=19.56.0
• loaded configuration file=package.json ("build" field)
• rebuilding native production dependencies platform=linux arch=x64
• rebuilding native dependency name=spellchecker
Done in 17.92s.
yarn run v1.6.0
$ gulp build --env=production
gulp[2126]: ../src/node_contextify.cc:631:static void
node::contextify::ContextifyScript::New(const
v8::FunctionCallbackInfo<v8::Value>&): Assert
ion `args[1]->IsString()' failed.
1: node::Abort() [gulp]
2: 0x55a77757c9db [gulp]
3: node::contextify::ContextifyScript::New(v8::FunctionCallbackInfo<v8::Value>
const&) [gulp]
4: v8::internal::FunctionCallbackArguments::Call(v8::internal::CallHandlerInfo*)
[gulp]
5: 0x55a777791ba7 [gulp]
6: 0x55a77779233c [gulp]
7: 0x36bc07f0427d
error Command failed with signal "SIGABRT".
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about
this command
Why this error? How to solved it?
Thanks in advanced.
Loading...