Discussion:
ofono install
(too old to reply)
Peter Nabbefeld
2017-02-01 22:06:31 UTC
Permalink
Raw Message
Hello,

I tried to install ofono from AUR, because I want HSP/HFP support for
pulseaudio
(https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Modules/#index35h3),
but I get an error about a conflict between .SRCINFO and PKGBUILD - how
can I resolve this problem?

Kind regards
Peter
Maxwell Anselm via arch-general
2017-02-01 22:52:56 UTC
Permalink
Raw Message
I get an error about a conflict between .SRCINFO and PKGBUILD - how can I
resolve this problem?
I'm not getting that error, have you tried cloning a fresh copy from AUR?
Regardless, you don't need to care about .SRCINFO unless you're the
maintainer. Just delete it.

Max
Peter Nabbefeld
2017-02-02 04:58:49 UTC
Permalink
Raw Message
Post by Maxwell Anselm via arch-general
I get an error about a conflict between .SRCINFO and PKGBUILD - how can I
resolve this problem?
I'm not getting that error, have you tried cloning a fresh copy from AUR?
Regardless, you don't need to care about .SRCINFO unless you're the
maintainer. Just delete it.
Max
I looked into these two files - version of .SRCINFO is 1.18, while in
PKGBUILD it is 1.19. Seems as if You have the "original" 1.18 build,
which is not updated because of unchanged .SRCINFO, so no conflicts.

As I'm installing the updated package, PKGBUILD loads version 1.19 of
ofono, which conflicts with .SRCINFO.

Peter
ProgAndy
2017-02-01 23:28:58 UTC
Permalink
Raw Message
Post by Peter Nabbefeld
Hello,
I tried to install ofono from AUR, because I want HSP/HFP support for
pulseaudio
(https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Modules/#index35h3),
but I get an error about a conflict between .SRCINFO and PKGBUILD -
how can I resolve this problem?
Kind regards
Peter
That sounds like you are using an AUR helper that compares the contents
of the PKGBUILD to the .SRCINFO file that provides the display data for
the AUR entry. The ofono maintainer only updated the PKGBUILD to 1.19
forgot to regenerate the SRCINFO (it still shows 1.18).

In this case you should build the package manually using makepkg and at
most a simple download helper like cower.


--

Andreas
Peter Nabbefeld
2017-02-02 05:08:55 UTC
Permalink
Raw Message
Post by ProgAndy
Post by Peter Nabbefeld
Hello,
I tried to install ofono from AUR, because I want HSP/HFP support for
pulseaudio
(https://www.freedesktop.org/wiki/Software/PulseAudio/Documentation/User/Modules/#index35h3),
but I get an error about a conflict between .SRCINFO and PKGBUILD -
how can I resolve this problem?
Kind regards
Peter
That sounds like you are using an AUR helper that compares the contents
of the PKGBUILD to the .SRCINFO file that provides the display data for
the AUR entry. The ofono maintainer only updated the PKGBUILD to 1.19
forgot to regenerate the SRCINFO (it still shows 1.18).
In this case you should build the package manually using makepkg and at
most a simple download helper like cower.
--
Andreas
I'm using pacaur, as it seems to be the easiest way to install AUR packages.

Peter
Eli Schwartz via arch-general
2017-02-02 06:05:37 UTC
Permalink
Raw Message
Post by Peter Nabbefeld
I'm using pacaur, as it seems to be the easiest way to install AUR packages.
And pacaur notices that the maintainer did something wrong, panics, and
aborts on you. pacaur actually uses the metadata from the .SRCINFO to
track what exists where, and packages which violate that expectation
confuse its parser.

It is entirely possible the built package exists in the cache somewhere.
--
Eli Schwartz
Peter Nabbefeld
2017-02-02 06:34:27 UTC
Permalink
Raw Message
Post by Eli Schwartz via arch-general
Post by Peter Nabbefeld
I'm using pacaur, as it seems to be the easiest way to install AUR packages.
And pacaur notices that the maintainer did something wrong, panics, and
aborts on you. pacaur actually uses the metadata from the .SRCINFO to
track what exists where, and packages which violate that expectation
confuse its parser.
It is entirely possible the built package exists in the cache somewhere.
In the meantime, I've managed to use makepkg --noextract --install on
the cached files after editing .SRCINFO to reflect the correct version
id. So I've got a running oFono 1.19 installation now, which will not be
upgraded before oFono 1.20 is out.

Regards
P.
Ralf Mardorf
2017-02-02 08:51:13 UTC
Permalink
Raw Message
Post by Peter Nabbefeld
after editing .SRCINFO to reflect the correct version
id.
Others already pointed out that you don't need this file to build a
package at all, apart from this you don't need to edit this file, simply
generate one:

"makepkg --printsrcinfo > .SRCINFO" -
https://wiki.archlinux.org/index.php/.SRCINFO
Peter Nabbefeld
2017-02-02 11:17:20 UTC
Permalink
Raw Message
Post by Ralf Mardorf
Post by Peter Nabbefeld
after editing .SRCINFO to reflect the correct version
id.
Others already pointed out that you don't need this file to build a
package at all, apart from this you don't need to edit this file, simply
"makepkg --printsrcinfo > .SRCINFO" -
https://wiki.archlinux.org/index.php/.SRCINFO
Thank You - I'll use that next time. Just wanted to have the correct
version info when using pacaur next time.

P.

Loading...