Discussion:
do i need to match bind and bind-tools versions ?
(too old to reply)
niya via arch-general
2018-08-05 13:23:10 UTC
Permalink
hi everyone

i need to install bind version 9.11 for a samba dc,
do i have to match bind-tools to the same version
or can i install the latest version of bind-tools version 9.13.
shadrock
Jens John
2018-08-05 14:59:08 UTC
Permalink
Post by niya via arch-general
hi everyone
i need to install bind version 9.11 for a samba dc,
do i have to match bind-tools to the same version
or can i install the latest version of bind-tools version 9.13.
shadrock
* On Arch bind-tools has no dependency on bind, so it should be
possible.

* Note that bind-tools 9.13 has some open bugs relating to IPv6 address
parsing in resolv.conf, so you might want to use bind-tools 9.11
anyway.

* If you need to deploy a bind service in a specific version, you may
want to consider using a containerized deployment to minimize
interference with the base system and maintenance burden as you
probably want to stay on the 9.11.x release train for a longer period
of time. Docker, LXC, LXD (only via AUR) would all work.

Loading...