Discussion:
Virtualbox under KDE plasma
(too old to reply)
Shridhar Daithankar
2018-02-13 03:03:09 UTC
Permalink
Hello,

I recently tried KDE plasma after 5.12 update and it is running smooth.
However I am experiencing two problems with virtualbox.

1. Virtualbox applications do not start unless QT_QPA_PLATFORM is set to xcb.
Under plasma wayland session it is set to wayland.

2. When a VM is launched, if it is maximized with Host-F, it loses all
keyboard/mouse interaction and has to be killed from the plasma session.

Anybody has seen this? Should I report it upstream?

Package details
virtualbox 5.2.6-2
kde plasma 5.12.0

Thanks.
--
Regards
Shridhar
Shridhar Daithankar
2018-02-13 05:13:44 UTC
Permalink
Post by Shridhar Daithankar
Hello,
I recently tried KDE plasma after 5.12 update and it is running smooth.
However I am experiencing two problems with virtualbox.
kde plasma wayland to be specific :( It all works under kde plasma Xorg.
Post by Shridhar Daithankar
1. Virtualbox applications do not start unless QT_QPA_PLATFORM is set to
xcb. Under plasma wayland session it is set to wayland.
2. When a VM is launched, if it is maximized with Host-F, it loses all
keyboard/mouse interaction and has to be killed from the plasma session.
Anybody has seen this? Should I report it upstream?
--
Regards
Shridhar
Bennett Piater
2018-02-13 07:21:45 UTC
Permalink
Post by Shridhar Daithankar
kde plasma wayland to be specific :( It all works under kde plasma Xorg.
Yes, do definitely file a bug upstream.

Also, plasma wayland is still considered experimental, so don't expect
it to work 100%. Should be stable enough for personal testing, but it's
not production ready.

IOW, if you want to use it, be prepared to file a few bugs :)

Cheers,
Bennett
--
GPG fingerprint: 871F 1047 7DB3 DDED 5FC4 47B2 26C7 E577 EF96 7808
Loading...